Overview

This is an adapter for the package database that connects it to Google Cloud Firestore.

This package works only in browsers. The package database_adapter_firestore_flutter can be used in Flutter.

Getting started

1.Add dependency

dependencies:
  database: any
  database_adapter_firestore_browser: any

2.Use it!

import 'package:database/database.dart';
import 'package:database_adapter_firestore_browser/database_adapter_firestore_browser.dart';

Database getDatabase() {
  return FirestoreBrowser().database();
}

Libraries

database_adapter_firebase_browser
Connects the package database to Google Cloud Firestore. Works only in browsers.