bento_support_widget

This is an flutter library for implementing bento support widget

Getting Started

This library would help you add Bento Support widget to your hybrid android/ios application in no time. All you need to do is ...

Install

To use this plugin, add bento_support_widget as a dependency in your pubspec.yaml file.

dependencies:
  bento_support_widget: ^1.0.0

Usage

                   initializeBentoSupport(
          context: context,
          publicKey: 'public key',
          onLogin: () {},
          key: 'unauthenticated',
          baseUrl: 'https://supportapi.bento.africa/api',
          child: Image.asset(
            'assets/img/png/chat_button.png',
            scale: 4,
          ),
          bottom: 300);

BentoSupportOptions

NameTypeRequiredDefault ValueDescription
keyStringtrueundefined

Data Dictionary

Notes Data Dictionary

Libraries

api_request_type
api_response
api_services
app_theme
auth.service
auth_controller
chat_bubble
chat_controller
chat_screen
client.model
client.service
client_controller
complaint
complaint.service
config
constants
create_complaint_dto
enums
loader.controller
loading_widget
main
message.service
organization.model
pagination
parser.service
route_names
router
socket.controller
socket.service
socket_message
support
support
support_background
theme_controller
user.model