SUPER_MIXINS_SETTING_DEPRECATED constant

AnalysisOptionsHintCode const SUPER_MIXINS_SETTING_DEPRECATED = const AnalysisOptionsHintCode('SUPER_MIXINS_SETTING_DEPRECATED', "The 'enableSuperMixins' setting is deprecated.", correction: "Support has been added to the language for 'mixin' based mixins.")

An error code indicating that the enablePreviewDart2 setting is deprecated.

Implementation

static const AnalysisOptionsHintCode SUPER_MIXINS_SETTING_DEPRECATED =
    AnalysisOptionsHintCode('SUPER_MIXINS_SETTING_DEPRECATED',
        "The 'enableSuperMixins' setting is deprecated.",
        correction:
            "Support has been added to the language for 'mixin' based mixins.")